8th February 2019

Enschede (DCT) Network degradation in DCT

Update 14:47: Our network is under attack by a DDoS attack (+/- 100 Gbit), which we have successfully mitigated. We are monitoring our network closely.

Update 14:22: We have investigated and identified a DDoS attack targeted on our network, currently we are trying to mitigate it.

Network performance issues have been reported in our data center DCT Enschede, we are investigating it now and we will update this post with new information.